Carenado has updated some of its FSX catalog aircraft to be P3Dv4 compatible. The new planes need to be uninstalled and downloaded again from Carenado. Vendors are getting updated packages too.

 

Here is the sixth batch of updated aircraft to make them usable in P3D version 4.

  • C208B Super Cargomaster Exp.Pack HD Series FSX/P3D (NEW SERIALS REQUIRED)
  • C208B Grand Caravan HD Series FSX/P3D (NEW SERIALS REQUIRED)
  • C185F Skywagon Bush FSX/P3D (NEW SERIALS REQUIRED)
  • C185F Skywagon FSX/P3D (NEW SERIALS REQUIRED)
  • PA34 200T Seneca II FSX/P3D (NEW SERIALS REQUIRED)

The NEW SERIAL REQUIRED label applies for aircraft bought at Carenado or any reseller.

Customers should download the package again from the link originally provided. Resellers already have them, please allow them one or two days to get them up in their sites.

You should uninstall the aircraft before installing this new version.

 

SHARE
Previous articleHeatblur AWG-9 / Jester Update
Next articleAeroFly FS2 Released !
Ishikawa
Passionnate about Simulators in general, and more specifically Flight Sim, I created this website so players can discover and get information about a wide range of simulators.